jeudi 14 novembre 2013

Excel : Les raccourcis




Vous avez une souris ? bien sûr...
Vous avez un clavier ? forcément...
Avez-vous déjà mesuré le temps que vous mettez à passer de l'un à l'autre ???
Cela peut correspondre à 2 sec par changement, le temps de remettre la flèche de la souris où on désire, retrouver les touches du clavier ensuite, ...etc.
Un moyen pour éviter cela : n'utiliser la souris que pour les actions qui le nécessitent.

Un premier exercice consiste à repérer les raccourcis clavier accessible pour une commande donnée :




Les commandes sont donc bien visibles. Elles le sont autant dans la plupart des applications dignes de ce nom :)

Parlons d'Excel maintenant que la table est mise.

Le déplacement dans Excel :

Tout le monde sait de déplacer d'une feuille à l'autre ou à l'intérieur d'une feuille à l'aide de la souris... mais sans le faire avec le clavier ?




La sélection dans Excel :
Pour affecter une mise en forme ou faire une action, il est nécessaire que la sélection de la zone considérée soit faite ; vous pouvez sélectionner des cellules à l'aide de la souris ou à l'aide du clavier :




à l'aide de la souris :




à l'aide du clavier :

Excel : formules avec les listes


Pour disposer d'une référence à une plage dont la taille est dynamique si on ajoute des lignes :

Créer une liste dans la feuille "LISTE" avec 4 colonnes.
Utiliser le menu Insertion -> Nom -> Définir
Dans la zone référence, copier la formule suivante :
=LISTE!$A$1:DECALER(LISTE!$D$1;NBVAL(LISTE!$A:$A)-1;0;1)
Désormais, si vous ajoutez des lignes à votre tableau, sans précaution particulière, la plage "LISTE" en tiendra compte.

Excel : formules avec les nombres


Dénombrer des valeurs sans les doublons :

Par ex :
"Plage" contient les valeurs suivantes : 1, 2, 2, 2, 7, 7, 4, 4, 4, 6, 6
On souhaite obtenir 5 (1, 2, 7, 4, et 6).
Saisir la formule suivante dans la cellule devant recevoir le résultat
=SOMME(1/NB.SI(Plage;Plage))
Pour avoir un résultat cohérent, il faut qu'elle soit validée en formule matricielle (CTRL+MAJ+ENTREE) au lieu de ENTREE.

Effectuer des arrondis "intelligents" :

Voici une utilisation de la fonction ARRONDI.SUP permettant d'arrondir un nombre (A1) en fonction de sa grandeur :
=ARRONDI.SUP(A1;-LOG(A1))


Déterminer la clé du n° de SECU :

si le numéro de sécu est en A1,
la clé est égale à
97-($A$1-97*ENT($A$1/97))
(sauf s'il y a des lettres, Corse...)

Excel : formules avec les dates


Obtenir la date du lundi qui débute la semaine B1 d'une année A1 :

=7*B1+DATE(A1;1;3)-JOURSEM(DATE(A1;1;3))-5
Ça marche aussi pour une date autre que le lundi !!

Obtenir le jour de la semaine d'une date A1 :

=TEXTE(A1;"jjjj")
L'avantage de cette formule est qu'elle renvoie du texte réutilisable dans d'autres cellules... il ne s'agit pas de la date formatée en "jjjj".
PS : vous pouvez remplacer jjjj par mmmm ou aaaa ou toute autre combinaison des j (jour), m (mois) et a (année).

Pour convertir une cellule A1 qui contient 1:30:00 en "1,5" :

=A1/"1:00:00"
Sans oublier de faire un CTRL+R (pour réinitialiser le format des nombres)

Pour connaître le n° de semaine d'une date :

=1+ENT(MIN(MOD(SUBSTITUE(A1;".";"/")-DATE(ANNEE(SUBSTITUE(A1;".";"/"))+{-1;0;1};1;5)+JOURSEM(DATE(ANNEE(SUBSTITUE(A1;".";"/"))+{-1;0;1};1;3));734))/7)
Attention au type de calendrier utilisé.


Pour connaître l'âge d'une personne :

=DATEDIF(A1;AUJOURDHUI();"y")&" ans et "&DATEDIF(A1;AUJOURDHUI();"ym")&" mois"